aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-11-10 19:17:16 +0100
committerMax Kellermann <max@duempel.org>2013-12-01 19:13:39 +0100
commit3e11a28cd9c204076407f02a600fcc617c7e0f3e (patch)
tree798cddd1c3804a558b1cdc885b70f5197e68d31e /Makefile.am
parent3ed80f31399c80a90bc3d2a845e739fff485d7c5 (diff)
downloadmpd-3e11a28cd9c204076407f02a600fcc617c7e0f3e.tar.gz
mpd-3e11a28cd9c204076407f02a600fcc617c7e0f3e.tar.xz
mpd-3e11a28cd9c204076407f02a600fcc617c7e0f3e.zip
pcm/SoxrResampler: new resampler option using libsoxr
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f3cd4531..74b838784 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -347,10 +347,12 @@ libpcm_a_SOURCES = \
src/pcm/PcmPrng.hxx \
src/pcm/PcmUtils.hxx
libpcm_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(SOXR_CFLAGS) \
$(SAMPLERATE_CFLAGS)
PCM_LIBS = \
libpcm.a \
+ $(SOXR_LIBS) \
$(SAMPLERATE_LIBS)
if HAVE_LIBSAMPLERATE
@@ -358,6 +360,11 @@ libpcm_a_SOURCES += \
src/pcm/LibsamplerateResampler.cxx src/pcm/LibsamplerateResampler.hxx
endif
+if HAVE_SOXR
+libpcm_a_SOURCES += \
+ src/pcm/SoxrResampler.cxx src/pcm/SoxrResampler.hxx
+endif
+
# File system library
libfs_a_SOURCES = \