aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-21 23:12:51 +0100
committerMax Kellermann <max@duempel.org>2014-02-22 00:18:46 +0100
commit3d4689756c8532551b80a3ba09586fa5d74e05fb (patch)
tree9a41945b6db8b022c4b2b24911d563b377576585 /Makefile.am
parent90114514a9d9439f7ed9519f2956bb00942771c5 (diff)
downloadmpd-3d4689756c8532551b80a3ba09586fa5d74e05fb.tar.gz
mpd-3d4689756c8532551b80a3ba09586fa5d74e05fb.tar.xz
mpd-3d4689756c8532551b80a3ba09586fa5d74e05fb.zip
Main: disable command-line parser and signal handlers on Android
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 9993b9ffa..35f43bae0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,7 +87,6 @@ libmpd_a_SOURCES = \
src/command/OtherCommands.cxx src/command/OtherCommands.hxx \
src/command/CommandListBuilder.cxx src/command/CommandListBuilder.hxx \
src/Idle.cxx src/Idle.hxx \
- src/CommandLine.cxx src/CommandLine.hxx \
src/CrossFade.cxx src/CrossFade.hxx \
src/decoder/DecoderError.cxx src/decoder/DecoderError.hxx \
src/decoder/DecoderThread.cxx src/decoder/DecoderThread.hxx \
@@ -125,9 +124,6 @@ libmpd_a_SOURCES = \
src/Instance.cxx src/Instance.hxx \
src/win32/Win32Main.cxx \
src/GlobalEvents.cxx src/GlobalEvents.hxx \
- src/unix/SignalHandlers.cxx src/unix/SignalHandlers.hxx \
- src/unix/Daemon.cxx src/unix/Daemon.hxx \
- src/unix/PidFile.hxx \
src/MixRampInfo.hxx \
src/MusicBuffer.cxx src/MusicBuffer.hxx \
src/MusicPipe.cxx src/MusicPipe.hxx \
@@ -177,6 +173,15 @@ libmpd_a_SOURCES = \
src/SongFilter.cxx src/SongFilter.hxx \
src/PlaylistFile.cxx src/PlaylistFile.hxx
+if ANDROID
+else
+libmpd_a_SOURCES += \
+ src/unix/SignalHandlers.cxx src/unix/SignalHandlers.hxx \
+ src/unix/Daemon.cxx src/unix/Daemon.hxx \
+ src/unix/PidFile.hxx \
+ src/CommandLine.cxx src/CommandLine.hxx
+endif
+
if ENABLE_DATABASE
libmpd_a_SOURCES += \
src/PlaylistUpdate.cxx \