aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-10-07 19:45:40 +0200
committerMax Kellermann <max@duempel.org>2014-10-09 07:45:25 +0200
commit3d2558bde6cebd6b628935f2852572cc7bb6eeab (patch)
treea2dcb1624f8d24cde3918c9ee955aae911c45417 /Makefile.am
parent1aac0b10c9499db77cbe39e43a0abc8cccc72079 (diff)
downloadmpd-3d2558bde6cebd6b628935f2852572cc7bb6eeab.tar.gz
mpd-3d2558bde6cebd6b628935f2852572cc7bb6eeab.tar.xz
mpd-3d2558bde6cebd6b628935f2852572cc7bb6eeab.zip
StoragePlugin: pass EventLoop to constructor
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 23a43d19b..213fda2e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1589,11 +1589,15 @@ endif
test_run_storage_LDADD = \
$(STORAGE_LIBS) \
$(FS_LIBS) \
+ libevent.a \
+ libthread.a \
libsystem.a \
libutil.a \
$(GLIB_LIBS)
test_run_storage_SOURCES = \
src/Log.cxx src/LogBackend.cxx \
+ src/IOThread.cxx \
+ test/ScopeIOThread.hxx \
test/run_storage.cxx
endif