aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-01-01 17:10:10 +0100
committerMax Kellermann <max@duempel.org>2010-01-01 17:10:10 +0100
commit3adfbfe36d84b7c2a510f348aa79d76d829dcdab (patch)
treee1d22e8d7d93217467b292758d248b0d77b6a54e /Makefile.am
parent9d3865cb952e95cfe8ac94f27f567f8408ec5b50 (diff)
downloadmpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.tar.gz
mpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.tar.xz
mpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.zip
configure.ac: expose variables OPENAL_CFLAGS and OPENAL_LIBS
Don't add these to the global MPD_CFLAGS and MPD_LIBS. This allows test programs to link without libopenal.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 020a2aeec..12bed50f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -599,6 +599,7 @@ OUTPUT_CFLAGS = \
$(AO_CFLAGS) \
$(ALSA_CFLAGS) \
$(JACK_CFLAGS) \
+ $(OPENAL_CFLAGS) \
$(PULSE_CFLAGS) \
$(SHOUT_CFLAGS)
@@ -606,6 +607,7 @@ OUTPUT_LIBS = \
$(AO_LIBS) \
$(ALSA_LIBS) \
$(JACK_LIBS) \
+ $(OPENAL_LIBS) \
$(PULSE_LIBS) \
$(SHOUT_LIBS)