aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-28 17:04:37 +0100
committerMax Kellermann <max@duempel.org>2009-02-28 17:04:37 +0100
commit362cc225587f967230e0ff144368336aa6a9d9d6 (patch)
tree0902acf7a9a1fbdf80ef2250ebffa3b07a90bec2 /Makefile.am
parent4a2b315ab6bcf9afc0718be980915870a4ee8f1f (diff)
downloadmpd-362cc225587f967230e0ff144368336aa6a9d9d6.tar.gz
mpd-362cc225587f967230e0ff144368336aa6a9d9d6.tar.xz
mpd-362cc225587f967230e0ff144368336aa6a9d9d6.zip
test: added test program which reads tags from a file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 613f9ef2a..63029b58f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -511,6 +511,7 @@ if ENABLE_TEST
noinst_PROGRAMS = \
test/run_decoder \
+ test/read_tags \
test/run_encoder \
test/software_volume
@@ -522,7 +523,22 @@ test_run_decoder_LDADD = $(MPD_LIBS) \
$(INPUT_LIBS) $(DECODER_LIBS)
test_run_decoder_SOURCES = test/run_decoder.c \
src/conf.c src/buffer2array.c src/utils.c src/log.c \
- src/tag.c src/tag_pool.c src/tag_id3.c \
+ src/tag.c src/tag_pool.c \
+ src/replay_gain.c \
+ src/uri.c \
+ $(ARCHIVE_SRC) \
+ $(INPUT_SRC) \
+ $(DECODER_SRC)
+
+test_read_tags_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(ID3TAG_CFLAGS) \
+ $(INPUT_CFLAGS) $(DECODER_CFLAGS)
+test_read_tags_LDADD = $(MPD_LIBS) \
+ $(ID3TAG_LIBS) \
+ $(INPUT_LIBS) $(DECODER_LIBS)
+test_read_tags_SOURCES = test/read_tags.c \
+ src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/tag.c src/tag_pool.c src/tag_ape.c \
src/replay_gain.c \
src/uri.c \
$(ARCHIVE_SRC) \
@@ -540,6 +556,12 @@ test_run_encoder_LDADD = $(MPD_LIBS) \
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \
src/pcm_volume.c
+
+if HAVE_ID3TAG
+test_run_decoder_SOURCES += src/tag_id3.c
+test_read_tags_SOURCES += src/tag_id3.c
+endif
+
endif