aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-26 10:52:46 +0200
committerMax Kellermann <max@duempel.org>2014-09-26 12:17:47 +0200
commit3120958a17f1fcbfc90d0c2ee2ede9e31c4cf09d (patch)
treebf4676aedfb4f6a1a900d8563c2448a30886d558 /Makefile.am
parent052726ed50f1600d5ffca41291528364435ff65e (diff)
downloadmpd-3120958a17f1fcbfc90d0c2ee2ede9e31c4cf09d.tar.gz
mpd-3120958a17f1fcbfc90d0c2ee2ede9e31c4cf09d.tar.xz
mpd-3120958a17f1fcbfc90d0c2ee2ede9e31c4cf09d.zip
pcm: --disable-dsd also disables the dsd2pcm library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f07cca401..65e500c5e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -464,8 +464,6 @@ libpcm_a_SOURCES = \
src/pcm/PcmBuffer.cxx src/pcm/PcmBuffer.hxx \
src/pcm/PcmExport.cxx src/pcm/PcmExport.hxx \
src/pcm/PcmConvert.cxx src/pcm/PcmConvert.hxx \
- src/pcm/dsd2pcm/dsd2pcm.c src/pcm/dsd2pcm/dsd2pcm.h \
- src/pcm/PcmDsd.cxx src/pcm/PcmDsd.hxx \
src/pcm/PcmDop.cxx src/pcm/PcmDop.hxx \
src/pcm/Volume.cxx src/pcm/Volume.hxx \
src/pcm/PcmMix.cxx src/pcm/PcmMix.hxx \
@@ -493,6 +491,12 @@ PCM_LIBS = \
$(SOXR_LIBS) \
$(SAMPLERATE_LIBS)
+if ENABLE_DSD
+libpcm_a_SOURCES += \
+ src/pcm/PcmDsd.cxx src/pcm/PcmDsd.hxx \
+ src/pcm/dsd2pcm/dsd2pcm.c src/pcm/dsd2pcm/dsd2pcm.h
+endif
+
if HAVE_LIBSAMPLERATE
libpcm_a_SOURCES += \
src/pcm/LibsamplerateResampler.cxx src/pcm/LibsamplerateResampler.hxx