aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-27 10:33:42 +0100
committerMax Kellermann <max@duempel.org>2014-01-27 10:33:42 +0100
commit30fadaed7fceb242f97776f189fcce1a2214604c (patch)
treefe055d1d1c959489f0dbb484e4f45e3994c8f89c /Makefile.am
parentc01282a322f13055cff9f68464b3b1750e59ee4f (diff)
parent2b10ecfa37e273c752c3f87e2491e2a1a5f0ae58 (diff)
downloadmpd-30fadaed7fceb242f97776f189fcce1a2214604c.tar.gz
mpd-30fadaed7fceb242f97776f189fcce1a2214604c.tar.xz
mpd-30fadaed7fceb242f97776f189fcce1a2214604c.zip
Merge branch 'v0.18.x'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2aa0614f5..ffa92e851 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1199,6 +1199,7 @@ C_TESTS = \
test/test_util \
test/test_byte_reverse \
test/test_mixramp \
+ test/test_icy_parser \
test/test_pcm \
test/test_translate_song \
test/test_queue_priority
@@ -1666,6 +1667,17 @@ test_test_mixramp_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+test_test_icy_parser_SOURCES = \
+ src/Log.cxx src/LogBackend.cxx \
+ test/test_icy_parser.cxx
+test_test_icy_parser_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_icy_parser_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_icy_parser_LDADD = \
+ libtag.a \
+ libutil.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_pcm_SOURCES = \
src/AudioFormat.cxx \
test/test_pcm_util.hxx \