aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-10-12 22:34:04 +0200
committerMax Kellermann <max@duempel.org>2009-10-12 22:34:04 +0200
commit2bf740fc71438edcb2c89e722ee8c83beb560128 (patch)
treee5b9c8b27a4a277a667b625d7c956882ff5bb710 /Makefile.am
parentdbb1e732b83645156ced0075444b1f309b66209c (diff)
downloadmpd-2bf740fc71438edcb2c89e722ee8c83beb560128.tar.gz
mpd-2bf740fc71438edcb2c89e722ee8c83beb560128.tar.xz
mpd-2bf740fc71438edcb2c89e722ee8c83beb560128.zip
playlist_plugin: new plugin API for playlist parsers
Based on this API, we will add parsers for EXTM3U, PLS, ASX, last.fm radio and others. There is no integration into the MPD core yet. Right now, we have a command line test program. This is work in progress.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c2f0fcf60..bd3b3f83d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,6 +136,9 @@ mpd_headers = \
src/playlist_print.h \
src/playlist_save.h \
src/playlist_state.h \
+ src/playlist_plugin.h \
+ src/playlist_list.h \
+ src/playlist/m3u_playlist_plugin.h \
src/poison.h \
src/riff.h \
src/aiff.h \
@@ -180,6 +183,7 @@ src_mpd_SOURCES = \
$(mpd_headers) \
$(ARCHIVE_SRC) \
$(INPUT_SRC) \
+ $(PLAYLIST_SRC) \
$(TAG_SRC) \
$(DECODER_SRC) \
$(ENCODER_SRC) \
@@ -641,6 +645,15 @@ endif
#
+# Playlist plugins
+#
+
+PLAYLIST_SRC = \
+ src/playlist/m3u_playlist_plugin.c \
+ src/playlist_list.c
+
+
+#
# Filter plugins
#
@@ -680,6 +693,7 @@ if ENABLE_TEST
noinst_PROGRAMS = \
test/read_conf \
test/run_input \
+ test/dump_playlist \
test/run_decoder \
test/read_tags \
test/run_filter \
@@ -707,6 +721,22 @@ test_run_input_SOURCES = test/run_input.c \
$(ARCHIVE_SRC) \
$(INPUT_SRC)
+test_dump_playlist_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(ARCHIVE_CFLAGS) \
+ $(INPUT_CFLAGS)
+test_dump_playlist_LDADD = $(MPD_LIBS) \
+ $(ARCHIVE_LIBS) \
+ $(INPUT_LIBS) \
+ $(GLIB_LIBS)
+test_dump_playlist_SOURCES = test/dump_playlist.c \
+ src/conf.c src/tokenizer.c src/utils.c \
+ src/uri.c \
+ src/song.c src/tag.c src/tag_pool.c src/tag_save.c \
+ src/text_input_stream.c src/fifo_buffer.c \
+ $(ARCHIVE_SRC) \
+ $(INPUT_SRC) \
+ $(PLAYLIST_SRC)
+
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
$(TAG_CFLAGS) \
$(ARCHIVE_CFLAGS) \