aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2015-10-26 13:16:01 +0100
committerMax Kellermann <max@duempel.org>2015-10-26 13:16:01 +0100
commit22ebe0e58f6fc7515f92cc78b406f6a3a2a68aa8 (patch)
tree8fc8b5847499d9f427a4fcac8a8911620219700a /Makefile.am
parentf072cbbba765e3b972655880970d65760a208843 (diff)
downloadmpd-22ebe0e58f6fc7515f92cc78b406f6a3a2a68aa8.tar.gz
mpd-22ebe0e58f6fc7515f92cc78b406f6a3a2a68aa8.tar.xz
mpd-22ebe0e58f6fc7515f92cc78b406f6a3a2a68aa8.zip
playlist/flac: re-add the plugin
This reverts commit d7d9dbd2c2798b6ff39acb07a3bed38b6f99e283 by reimplementing it with the current MPD API. 3 years ago, I was wrong about the "embcue" plugin being able to replace this one, because "embcue" reads a tag named "CUESHEET", while this plugin reads the "CUESHEET" FLAC metablock. There's an important difference between those two!
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a82d708b..c846d7411 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1479,6 +1479,12 @@ PLAYLIST_LIBS = \
$(EXPAT_LIBS) \
$(FLAC_LIBS)
+if ENABLE_FLAC
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/plugins/FlacPlaylistPlugin.cxx \
+ src/playlist/plugins/FlacPlaylistPlugin.hxx
+endif
+
if ENABLE_CUE
libplaylist_plugins_a_SOURCES += \
src/playlist/cue/CueParser.cxx src/playlist/cue/CueParser.hxx \