aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-03-01 09:19:32 +0100
committerMax Kellermann <max@duempel.org>2014-03-01 18:48:20 +0100
commit1e06c66c776e2dca217059d7d94309b0c5431a3f (patch)
tree64b3bf4c5051fabf9dff5b9d0c3ed73b3d2bb45b /Makefile.am
parentc73771e3ce7a5866f5ddc70d1cc03acf6a104127 (diff)
downloadmpd-1e06c66c776e2dca217059d7d94309b0c5431a3f.tar.gz
mpd-1e06c66c776e2dca217059d7d94309b0c5431a3f.tar.xz
mpd-1e06c66c776e2dca217059d7d94309b0c5431a3f.zip
java: new helper library for the Android port
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a9482c64..c4235e60b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -242,11 +242,23 @@ UPNP_SOURCES = \
if ANDROID
+noinst_LIBRARIES += libjava.a
+libjava_a_SOURCES = \
+ src/java/Class.hxx \
+ src/java/Exception.hxx \
+ src/java/Global.cxx src/java/Global.hxx \
+ src/java/Object.hxx \
+ src/java/Ref.hxx \
+ src/java/File.cxx src/java/File.hxx \
+ src/java/String.cxx src/java/String.hxx
+
noinst_LIBRARIES += libmain.a
libmain_a_SOURCES = \
src/Main.cxx src/Main.hxx
libmain_a_CPPFLAGS = $(AM_CPPFLAGS) -Iandroid/build/include
+src_mpd_LDADD += libjava.a
+
all-local: android/build/bin/Main-debug.apk
clean-local:
rm -rf android/build