aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJochen Keil <jochen.keil@gmail.com>2009-03-31 21:48:04 +0200
committerJochen Keil <jochen.keil@gmail.com>2009-03-31 22:17:56 +0200
commit192e29107d874b952b267b3584bf154da3314827 (patch)
tree4ebc16c41445eebcf7a024eacfd8c74653620a5a /Makefile.am
parentd41e7f7cec3b4000ffc41d91ef1a612937a04625 (diff)
downloadmpd-192e29107d874b952b267b3584bf154da3314827.tar.gz
mpd-192e29107d874b952b267b3584bf154da3314827.tar.xz
mpd-192e29107d874b952b267b3584bf154da3314827.zip
Configure/Make dependencies for cue/cue_tag.h/.c
Autoconf/automake support for libcue which is needed for cue/cue_tag.h/.c. Libcue will have/has pkg-config support so this is fairly straightforward.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 34e46a87d..c11e8db11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,7 +152,8 @@ mpd_headers = \
src/archive_api.h \
src/archive_internal.h \
src/archive_list.h \
- src/input/archive_input_plugin.h
+ src/input/archive_input_plugin.h \
+ src/cue/cue_tag.h
src_mpd_SOURCES = \
$(mpd_headers) \
@@ -295,7 +296,8 @@ DECODER_CFLAGS = \
$(FLUIDSYNTH_CFLAGS) \
$(WILDMIDI_CFLAGS) \
$(MAD_CFLAGS) \
- $(FFMPEG_CFLAGS)
+ $(FFMPEG_CFLAGS) \
+ $(CUE_CFLAGS)
DECODER_LIBS = \
$(OGGVORBIS_LIBS) $(FLAC_LIBS) \
@@ -306,7 +308,8 @@ DECODER_LIBS = \
$(WILDMIDI_LIBS) \
$(MAD_LIBS) \
$(MP4FF_LIBS) \
- $(FFMPEG_LIBS)
+ $(FFMPEG_LIBS) \
+ $(CUE_LIBS)
DECODER_SRC = \
src/decoder_buffer.c \
@@ -415,6 +418,9 @@ src_mpd_SOURCES += src/zeroconf-bonjour.c
endif
endif
+if HAVE_CUE
+DECODER_SRC += src/cue/cue_tag.c
+endif
#
# input plugins