aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-02-12 15:20:38 +0100
committerMax Kellermann <max@duempel.org>2012-02-12 16:10:20 +0100
commit1735284a2ac1773614786b9f5caf50fa29347654 (patch)
tree10837862ab981fa2ec97cdec2008ea5370bc2375 /Makefile.am
parent8a3192ffc16c54b1d50ea190f1e3d4f941ceefd1 (diff)
downloadmpd-1735284a2ac1773614786b9f5caf50fa29347654.tar.gz
mpd-1735284a2ac1773614786b9f5caf50fa29347654.tar.xz
mpd-1735284a2ac1773614786b9f5caf50fa29347654.zip
playlist/embcue: new plugin for reading embedded cue sheets
Parses CUE data from the "CUESHEET" tag. Needs further integration in the update thread.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 636bf0648..977a9c22d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -336,6 +336,7 @@ src_mpd_SOURCES = \
src/tag_print.c \
src/tag_save.c \
src/tag_handler.c src/tag_handler.h \
+ src/tag_file.c src/tag_file.h \
src/tokenizer.c \
src/text_file.c \
src/text_input_stream.c \
@@ -864,6 +865,8 @@ libplaylist_plugins_a_SOURCES = \
src/playlist/asx_playlist_plugin.c \
src/playlist/rss_playlist_plugin.c \
src/playlist/cue_playlist_plugin.c \
+ src/playlist/embcue_playlist_plugin.c \
+ src/playlist/embcue_playlist_plugin.h \
src/playlist_list.c
libplaylist_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS))
@@ -1001,15 +1004,20 @@ test_dump_playlist_LDADD = \
$(FLAC_LIBS) \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
+ $(DECODER_LIBS) \
+ $(TAG_LIBS) \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.c \
+ $(DECODER_SRC) \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
src/uri.c \
src/song.c src/tag.c src/tag_pool.c src/tag_save.c \
- src/tag_handler.c \
+ src/tag_handler.c src/tag_file.c \
+ src/audio_check.c src/pcm_buffer.c \
src/text_input_stream.c src/fifo_buffer.c \
src/cue/cue_parser.c src/cue/cue_parser.h \
+ src/timer.c \
src/fd_util.c
if HAVE_FLAC