aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-09-04 09:26:18 +0200
committerMax Kellermann <max@duempel.org>2012-09-05 23:01:17 +0200
commit1536b5a9d602688354648106ca8d0e34cac3c933 (patch)
treeb10491abb2502bf399a1f2c6184894bcfcf0ec17 /Makefile.am
parentbab756a5d06463f992ece8c9ec0a5dfb8e4007c9 (diff)
downloadmpd-1536b5a9d602688354648106ca8d0e34cac3c933.tar.gz
mpd-1536b5a9d602688354648106ca8d0e34cac3c933.tar.xz
mpd-1536b5a9d602688354648106ca8d0e34cac3c933.zip
src/decoder/opus: new decoder plugin for the Opus codec
Using libopus and libogg.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a0f4b2a77..ed284b50a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -538,6 +538,7 @@ libdecoder_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(WAVPACK_CFLAGS) \
$(MAD_CFLAGS) \
$(MPG123_CFLAGS) \
+ $(OPUS_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(MPCDEC_CFLAGS) \
$(FAAD_CFLAGS)
@@ -555,6 +556,7 @@ DECODER_LIBS = \
$(WAVPACK_LIBS) \
$(MAD_LIBS) \
$(MPG123_LIBS) \
+ $(OPUS_LIBS) \
$(MP4FF_LIBS) \
$(FFMPEG_LIBS) \
$(MPCDEC_LIBS) \
@@ -574,6 +576,19 @@ if HAVE_MPCDEC
libdecoder_plugins_a_SOURCES += src/decoder/mpcdec_decoder_plugin.c
endif
+if HAVE_OPUS
+libdecoder_plugins_a_SOURCES += \
+ src/decoder/OggUtil.cxx \
+ src/decoder/OggUtil.hxx \
+ src/decoder/OpusReader.hxx \
+ src/decoder/OpusHead.hxx \
+ src/decoder/OpusHead.cxx \
+ src/decoder/OpusTags.cxx \
+ src/decoder/OpusTags.hxx \
+ src/decoder/OpusDecoderPlugin.cxx \
+ src/decoder/OpusDecoderPlugin.h
+endif
+
if HAVE_WAVPACK
libdecoder_plugins_a_SOURCES += src/decoder/wavpack_decoder_plugin.c
endif