aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-17 23:45:46 +0100
committerMax Kellermann <max@duempel.org>2014-02-18 09:18:42 +0100
commit13056af8b24a86f8fcdaa0956dfd61071ae69932 (patch)
treed3fcbd50d9815e758fe8b5e239b4be457e3c8248 /Makefile.am
parent972c52891dce36e19d8fb67e55246a19ee9bbb5a (diff)
downloadmpd-13056af8b24a86f8fcdaa0956dfd61071ae69932.tar.gz
mpd-13056af8b24a86f8fcdaa0956dfd61071ae69932.tar.xz
mpd-13056af8b24a86f8fcdaa0956dfd61071ae69932.zip
Makefile.am: disable test_icy_parser without CURL
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 80fc32d22..9672de8f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1266,10 +1266,13 @@ C_TESTS = \
test/test_util \
test/test_byte_reverse \
test/test_mixramp \
- test/test_icy_parser \
test/test_pcm \
test/test_queue_priority
+if ENABLE_CURL
+C_TESTS += test/test_icy_parser
+endif
+
if ENABLE_DATABASE
C_TESTS += test/test_translate_song
endif
@@ -1744,6 +1747,7 @@ test_test_mixramp_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+if ENABLE_CURL
test_test_icy_parser_SOURCES = \
src/Log.cxx src/LogBackend.cxx \
test/test_icy_parser.cxx
@@ -1754,6 +1758,7 @@ test_test_icy_parser_LDADD = \
libutil.a \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+endif
test_test_pcm_SOURCES = \
src/AudioFormat.cxx \