aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-11 01:01:54 +0100
committerMax Kellermann <max@duempel.org>2014-01-11 01:01:54 +0100
commit114df1f137d5a32cdde64d43712fb602c2f93ebb (patch)
treeb0f1b51cfed7ef50b1e98a241dcfd8d8c17a2791 /Makefile.am
parent00adf7ff173afbe7fe13734a27d6ee19096ce640 (diff)
downloadmpd-114df1f137d5a32cdde64d43712fb602c2f93ebb.tar.gz
mpd-114df1f137d5a32cdde64d43712fb602c2f93ebb.tar.xz
mpd-114df1f137d5a32cdde64d43712fb602c2f93ebb.zip
DatabasePlugin: add interface DatabaseListener
Allow database plugins to announce that they have been modified.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bcd251cca..66186ec9c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,6 +114,7 @@ src_mpd_SOURCES = \
src/DatabaseLock.cxx src/DatabaseLock.hxx \
src/DatabaseSave.cxx src/DatabaseSave.hxx \
src/DatabasePlugin.hxx \
+ src/DatabaseListener.hxx \
src/DatabaseVisitor.hxx \
src/DatabaseSelection.cxx src/DatabaseSelection.hxx \
src/ExcludeList.cxx src/ExcludeList.hxx \
@@ -1202,6 +1203,7 @@ test_DumpDatabase_LDADD = \
$(TAG_LIBS) \
libconf.a \
libutil.a \
+ libevent.a \
libsystem.a \
libfs.a \
$(GLIB_LIBS)