aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-15 07:14:36 +0100
committerMax Kellermann <max@duempel.org>2013-01-15 18:16:55 +0100
commit083065f433cb513156878a33ebe5723ae27057da (patch)
tree83277c531a16f1d20e33c818d59e5d96d0062d00 /Makefile.am
parent4cfc4a5a9441479bc3f279edd40683d5e3eaf941 (diff)
downloadmpd-083065f433cb513156878a33ebe5723ae27057da.tar.gz
mpd-083065f433cb513156878a33ebe5723ae27057da.tar.xz
mpd-083065f433cb513156878a33ebe5723ae27057da.zip
input/Curl: move code to class MultiSocketMonitor
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index eca6d7d7c..38d31b26b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -359,6 +359,7 @@ libevent_a_SOURCES = \
src/event/TimeoutMonitor.hxx src/event/TimeoutMonitor.cxx \
src/event/SocketMonitor.cxx src/event/SocketMonitor.hxx \
src/event/BufferedSocket.cxx src/event/BufferedSocket.hxx \
+ src/event/MultiSocketMonitor.cxx src/event/MultiSocketMonitor.hxx \
src/event/Loop.hxx
# PCM library
@@ -1070,6 +1071,7 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
test_run_input_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
+ libevent.a \
$(GLIB_LIBS)
test_run_input_SOURCES = test/run_input.c \
test/stdbin.h \
@@ -1080,9 +1082,10 @@ test_run_input_SOURCES = test/run_input.c \
src/fd_util.c
test_dump_text_file_LDADD = \
- libutil.a \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
+ libevent.a \
+ libutil.a \
$(GLIB_LIBS)
test_dump_text_file_SOURCES = test/dump_text_file.cxx \
test/stdbin.h \
@@ -1100,6 +1103,7 @@ test_dump_playlist_LDADD = \
$(ARCHIVE_LIBS) \
$(DECODER_LIBS) \
$(TAG_LIBS) \
+ libevent.a \
libutil.a \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.cxx \
@@ -1126,6 +1130,7 @@ test_run_decoder_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
+ libevent.a \
libutil.a \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.cxx \
@@ -1149,6 +1154,7 @@ test_read_tags_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \
$(TAG_LIBS) \
+ libevent.a \
libutil.a \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.cxx \