aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-01-22 01:31:29 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-01-22 01:31:29 +0600
commit06fb7c671bb97a467e34a3d89c2527e342706245 (patch)
tree7cf1066a995ee51c43d43f893e6f06a77d003059 /Makefile.am
parentef93cdf4a8b654342e97e6ab707caaf42cb9c64d (diff)
downloadmpd-06fb7c671bb97a467e34a3d89c2527e342706245.tar.gz
mpd-06fb7c671bb97a467e34a3d89c2527e342706245.tar.xz
mpd-06fb7c671bb97a467e34a3d89c2527e342706245.zip
Makefile.am: introduce libfs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index adcc21e15..852c28707 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,7 @@ noinst_LIBRARIES = \
libpcm.a \
libtag.a \
libinput.a \
+ libfs.a \
libdb_plugins.a \
libplaylist_plugins.a \
libdecoder_plugins.a \
@@ -41,6 +42,7 @@ src_mpd_LDADD = \
$(MIXER_LIBS) \
libevent.a \
libutil.a \
+ libfs.a \
$(SYSTEMD_DAEMON_LIBS) \
$(GLIB_LIBS)
@@ -151,9 +153,6 @@ src_mpd_SOURCES = \
src/thread/PosixCond.hxx \
src/thread/WindowsCond.hxx \
src/thread/GLibCond.hxx \
- src/fs/Path.cxx src/fs/Path.hxx \
- src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
- src/fs/DirectoryReader.hxx \
src/glib_socket.h \
src/clock.c src/clock.h \
src/notify.cxx src/notify.hxx \
@@ -382,6 +381,13 @@ if HAVE_LIBSAMPLERATE
libpcm_a_SOURCES += src/pcm_resample_libsamplerate.c
endif
+# File system library
+
+libfs_a_SOURCES = \
+ src/fs/Path.cxx src/fs/Path.hxx \
+ src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
+ src/fs/DirectoryReader.hxx
+
# database plugins
libdb_plugins_a_SOURCES = \
@@ -1051,6 +1057,7 @@ test_run_resolver_SOURCES = test/run_resolver.c \
test_DumpDatabase_LDADD = \
$(DB_LIBS) \
libutil.a \
+ libfs.a \
$(GLIB_LIBS)
test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/DatabaseRegistry.cxx \
@@ -1060,7 +1067,6 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/DatabaseLock.cxx src/DatabaseSave.cxx \
src/Song.cxx src/song_sort.c src/SongSave.cxx \
src/Tag.cxx src/TagNames.c src/TagPool.cxx src/TagSave.cxx \
- src/fs/Path.cxx \
src/SongFilter.cxx \
src/TextFile.cxx \
src/ConfigFile.cxx src/tokenizer.c src/utils.c src/string_util.c