aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-18 21:05:04 +0100
committerMax Kellermann <max@duempel.org>2014-02-18 21:47:01 +0100
commit0053cd0d0d5a9b5ef54d604d2c650ee3803a04e5 (patch)
tree61620a43dd7e47994fa97d4b2b44e704fac3be06 /Makefile.am
parentc32477a223ad09dc0fc0708e95e09799eecb930b (diff)
downloadmpd-0053cd0d0d5a9b5ef54d604d2c650ee3803a04e5.tar.gz
mpd-0053cd0d0d5a9b5ef54d604d2c650ee3803a04e5.tar.xz
mpd-0053cd0d0d5a9b5ef54d604d2c650ee3803a04e5.zip
Main: disable inotify check without database
Fix build failure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b84a67316..2decacbd8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -249,6 +249,7 @@ src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
src_mpd_LDFLAGS = -Wl,src/win32/mpd_win32_rc.$(OBJEXT)
endif
+if ENABLE_DATABASE
if ENABLE_INOTIFY
src_mpd_SOURCES += \
src/db/update/InotifyDomain.cxx src/db/update/InotifyDomain.hxx \
@@ -256,6 +257,7 @@ src_mpd_SOURCES += \
src/db/update/InotifyQueue.cxx src/db/update/InotifyQueue.hxx \
src/db/update/InotifyUpdate.cxx src/db/update/InotifyUpdate.hxx
endif
+endif
if ENABLE_SQLITE
src_mpd_SOURCES += \