aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Sapiro <msapiro@value.net>2007-09-21 15:22:15 -0700
committerMark Sapiro <msapiro@value.net>2007-09-21 15:22:15 -0700
commite9fddb3a006bae8de058508f8ab5d3e0ca289ffa (patch)
tree0ed253da67d76525b26f76bbbb16cbc17bbf0eef /configure.in
parent06622797ea56104b960932c992d6719c5a6251ca (diff)
downloadmailman2-e9fddb3a006bae8de058508f8ab5d3e0ca289ffa.tar.gz
mailman2-e9fddb3a006bae8de058508f8ab5d3e0ca289ffa.tar.xz
mailman2-e9fddb3a006bae8de058508f8ab5d3e0ca289ffa.zip
It is reported that some RedHat packages (for at least FC5 and FC6, but not
FC7) contain a full working distutils in the 'python' package, but only contain the Python header files in the 'python-devel' package. This allows configure to succeed, but make install fails to setup the japanese and korean codecs. This change adds a specific test for Python.h to the distutils test.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 55454148..b97df6d2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# Copyright (C) 1998-2006 by the Free Software Foundation, Inc.
+# Copyright (C) 1998-2007 by the Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
@@ -101,7 +101,14 @@ else:
except distutils.errors.DistutilsPlatformError:
res = "no"
else:
- res = "yes"
+ # some RedHat packages put distutils in python, but the C headers
+ # are in python-devel so check for headers too.
+ import os.path
+ pdothpath = distutils.sysconfig.get_config_var('CONFINCLUDEPY')
+ if os.path.isfile(os.path.join(pdothpath, "Python.h")):
+ res = "yes"
+ else:
+ res = "no"
fp = open("conftest.out", "w")
fp.write("%s\n" % res)
fp.close()
@@ -117,7 +124,8 @@ then
***** Distutils is not available or is incomplete for $PYTHON
***** If you installed Python from RPM (or other package manager)
***** be sure to install the -devel package, or install Python
-***** from source. See README.LINUX for details])
+***** from source. See sec. 15.1 of the Installation Manual for
+***** details])
fi
AC_MSG_RESULT($havedistutils)