aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f9f6e11..e0846256 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,9 +170,12 @@ PKG_HAVE([sqlite3], [sqlite3], yes)
# (K)Ubuntu uses lua5.1.pc, Mac OS X and other
# linux distributions use lua.pc
PKG_HAVE([lua], [lua5.1], no)
+lua_LIB_NAME="lua5.1"
if [[ x$lua_HAVE = xno ]]; then
PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_LIB_NAME="lua"
fi
+AC_SUBST(lua_LIB_NAME)
# find FFMpeg
# Note: do not use the min/max version parameters with ffmpeg