aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69e358fc..25537088 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,20 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
+# find pcre
+AC_ARG_WITH(pcre,
+ [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
+ [
+ CPPFLAGS="$CPPFLAGS -I $withval/include"
+ LDFLAGS="$LDFLAGS -L $withval/lib"
+ ]
+)
+
+AC_CHECK_HEADERS(pcre.h,
+ AC_SEARCH_LIBS([pcre_compile], [pcre]) ,
+ AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre])
+)
+
# find FFMpeg
# Note: do not use the min/max version parameters with ffmpeg
# otherwise it might fail in ubuntu due to a wrong version number