aboutsummaryrefslogtreecommitdiffstats
path: root/cmake/src/lib/projectM/cwrapper/CMakeLists.txt
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-05-11 19:59:01 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-05-11 19:59:01 +0000
commit3bac1f9c6c02cbe30f4fbed37366482fcc687e03 (patch)
tree3549fe136d4843db1856c190060d73dc7325ef4f /cmake/src/lib/projectM/cwrapper/CMakeLists.txt
parent17deba0bcda7f39696bad713bc2c0bc49ec4fb59 (diff)
downloadusdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.tar.gz
usdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.tar.xz
usdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.zip
- Package flags (FLAGS / LIBRARY_FLAGS)
- -k"-U sdl_main" for Mac OS X defined as SDL package LIBRARY_FLAG - plugins moved to game/plugins - BUILD_PLUGINS option added to disable plugin creation (if linking of libraries fails) - PASCAL_FLAGS_... added git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/branches/experimental@1722 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to '')
-rw-r--r--cmake/src/lib/projectM/cwrapper/CMakeLists.txt18
1 files changed, 8 insertions, 10 deletions
diff --git a/cmake/src/lib/projectM/cwrapper/CMakeLists.txt b/cmake/src/lib/projectM/cwrapper/CMakeLists.txt
index acca3025..3c84736a 100644
--- a/cmake/src/lib/projectM/cwrapper/CMakeLists.txt
+++ b/cmake/src/lib/projectM/cwrapper/CMakeLists.txt
@@ -1,13 +1,11 @@
# $URL$
# $Id$
-if(libprojectM_USE_CWRAPPER)
- include_directories(${libprojectM_INCLUDEDIR}/libprojectM)
- add_definitions(-DPROJECTM_VERSION_INT=${libprojectM_VERSION_INT})
+include_directories(${libprojectM_INCLUDEDIR}/libprojectM)
+add_definitions(-DPROJECTM_VERSION_INT=${libprojectM_VERSION_INT})
- set(projectm_cwrapper_srcs projectM-cwrapper.cpp)
- if(WIN32)
- add_library(projectM-cwrapper SHARED ${projectm_cwrapper_srcs})
- else(WIN32)
- add_library(projectM-cwrapper STATIC ${projectm_cwrapper_srcs})
- endif(WIN32)
-endif(libprojectM_USE_CWRAPPER)
+set(projectm_cwrapper_srcs projectM-cwrapper.cpp)
+if(WIN32)
+ add_library(projectM-cwrapper EXCLUDE_FROM_ALL SHARED ${projectm_cwrapper_srcs})
+else(WIN32)
+ add_library(projectM-cwrapper EXCLUDE_FROM_ALL STATIC ${projectm_cwrapper_srcs})
+endif(WIN32)