aboutsummaryrefslogtreecommitdiffstats
path: root/cmake/dists/gentoo/ultrastardx-9999.ebuild
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-05-11 19:59:01 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-05-11 19:59:01 +0000
commit3bac1f9c6c02cbe30f4fbed37366482fcc687e03 (patch)
tree3549fe136d4843db1856c190060d73dc7325ef4f /cmake/dists/gentoo/ultrastardx-9999.ebuild
parent17deba0bcda7f39696bad713bc2c0bc49ec4fb59 (diff)
downloadusdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.tar.gz
usdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.tar.xz
usdx-3bac1f9c6c02cbe30f4fbed37366482fcc687e03.zip
- Package flags (FLAGS / LIBRARY_FLAGS)
- -k"-U sdl_main" for Mac OS X defined as SDL package LIBRARY_FLAG - plugins moved to game/plugins - BUILD_PLUGINS option added to disable plugin creation (if linking of libraries fails) - PASCAL_FLAGS_... added git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/branches/experimental@1722 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'cmake/dists/gentoo/ultrastardx-9999.ebuild')
-rw-r--r--cmake/dists/gentoo/ultrastardx-9999.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/cmake/dists/gentoo/ultrastardx-9999.ebuild b/cmake/dists/gentoo/ultrastardx-9999.ebuild
index 7b092919..b1ffb5a4 100644
--- a/cmake/dists/gentoo/ultrastardx-9999.ebuild
+++ b/cmake/dists/gentoo/ultrastardx-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header $
-inherit subversion eutils games
+inherit subversion cmake-utils games
SONGS_PKG=USDX-SongPackage
SONGS_VER=01
@@ -34,7 +34,7 @@ RDEPEND="virtual/opengl
projectm? ( media-libs/libprojectm )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- >=dev-lang/fpc-2.2.0"
+ >=dev-lang/fpc-2.2.2"
S=${WORKDIR}/${P}-src
@@ -50,10 +50,22 @@ src_unpack() {
}
src_compile() {
- egamesconf \
- $(use_with projectm libprojectM) \
- $(use_enable debug) \
- || die
+ if use projectm ; then
+ enable_projectm="ON"
+ else
+ enable_projectm="OFF"
+ fi
+ if use debug ; then
+ build_type="Debug"
+ else
+ build_type="Release"
+ fi
+ cmake \
+ -DCMAKE_BUILD_TYPE=$build_type \
+ -DENABLE_PROJECTM=$enable_projectm \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ . \
+ || die "cmake failed"
emake || die "emake failed"
}