aboutsummaryrefslogtreecommitdiffstats
path: root/x11-misc/mimeo/mimeo-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mimeo/mimeo-0.2.ebuild')
-rw-r--r--x11-misc/mimeo/mimeo-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/mimeo/mimeo-0.2.ebuild b/x11-misc/mimeo/mimeo-0.2.ebuild
new file mode 100644
index 0000000..b04556f
--- /dev/null
+++ b/x11-misc/mimeo/mimeo-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python
+
+DESCRIPTION="open files using mimetype associations"
+HOMEPAGE="http://xyne.archlinux.ca/info/mimeo"
+SRC_URI="http://xyne.archlinux.ca/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_install() {
+ insinto $(python_get_sitedir)/${PN}
+ newins mimeo/mimeo mimeo.py
+ doins ${FILESDIR}/__init__.py
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/mimeo
+ doexe ${FILESDIR}/mimeo-2.6
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}