aboutsummaryrefslogtreecommitdiffstats
path: root/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild b/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
new file mode 100644
index 0000000..16891ee
--- /dev/null
+++ b/sys-power/acpi-fakekey/acpi-fakekey-0.140.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Script from Ubuntu to create key events from acpi scripts"
+HOMEPAGE="http://packages.ubuntu.com/feisty/admin/acpi-support"
+SRC_URI="mirror://ubuntu/pool/main/a/acpi-support/acpi-support_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/kbd"
+S="${WORKDIR}/acpi-support-${PV}"
+
+src_compile() {
+ cd "$S"
+ sed -i 's/strip acpi_fakekey//' Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin acpi_fakekey
+
+ insinto /usr/share/${PN}
+ doins key-constants
+}