aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/unyaffs/unyaffs-0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sys-fs/unyaffs/unyaffs-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/unyaffs/unyaffs-0.1.ebuild b/sys-fs/unyaffs/unyaffs-0.1.ebuild
new file mode 100644
index 0000000..ee4f29d
--- /dev/null
+++ b/sys-fs/unyaffs/unyaffs-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a program to extract files from a yaffs image"
+HOMEPAGE="http://code.google.com/p/unyaffs/"
+SRC_URI="http://unyaffs.googlecode.com/files/unyaffs.c
+ http://unyaffs.googlecode.com/files/unyaffs.h"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT="0"
+
+DEPENDS=""
+RDEPENDS=""
+
+src_unpack() {
+ for source in ${A} ; do
+ cp ${DISTDIR}/${source} ${WORKDIR}
+ done
+}
+
+src_compile() {
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+}