aboutsummaryrefslogtreecommitdiffstats
path: root/net-libs/npm/npm-1.0.105.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/npm/npm-1.0.105.ebuild')
-rw-r--r--net-libs/npm/npm-1.0.105.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/npm/npm-1.0.105.ebuild b/net-libs/npm/npm-1.0.105.ebuild
new file mode 100644
index 0000000..f5fcb04
--- /dev/null
+++ b/net-libs/npm/npm-1.0.105.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A package manager for nodejs."
+HOMEPAGE="http://npmjs.org"
+SRC_URI="http://registry.npmjs.org/npm/-/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND} net-libs/nodejs"
+
+S="${WORKDIR}/package"
+
+src_configure() {
+ econf --prefix="${D}usr/" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}usr/" install || die
+ dodoc README.md CHANGES || die
+ dodoc -r doc/ || die
+
+ # fix npm paths
+ sed -i "s~${D}usr~@PREFIX@~" ${D}usr/lib/node_modules/npm/npmrc
+}
+
+pkg_postinst() {
+ #fix npm paths
+ sed -i "s~@PREFIX@~${ROOT}usr/~" ${ROOT}usr/lib/node_modules/npm/npmrc
+}