aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/qwebirc/qwebirc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--net-irc/qwebirc/qwebirc-9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-irc/qwebirc/qwebirc-9999.ebuild b/net-irc/qwebirc/qwebirc-9999.ebuild
new file mode 100644
index 0000000..ac98b6c
--- /dev/null
+++ b/net-irc/qwebirc/qwebirc-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EHG_REPO_URI=http://hg.qwebirc.org/qwebirc/
+
+inherit eutils mercurial
+
+EAPI=2
+
+DESCRIPTION="qwebirc is a fast, easy to use, free and open source IRC client designed by and originally just for the QuakeNet IRC network."
+HOMEPAGE="http://www.qwebirc.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.5
+ dev-python/simplejson
+ >=dev-python/twisted-mail-8.2
+ >=dev-python/twisted-names-8.2
+ >=dev-python/twisted-web-8.2
+ >=dev-python/twisted-words-8.2
+ >=virtual/jre-1.6
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup qwebirc
+ enewuser qwebirc -1 /bin/true /var/lib/qwebirc qwebirc -r -d /var/www/qwebirc
+}
+
+src_compile() {
+ ./compile.py
+}
+
+src_install() {
+ mkdir -p ${D}/var/www
+ # copy the whole repository, including the .hg stuff
+ cp -rp ${S} ${D}/var/www/qwebirc
+ chown -R qwebirc:qwebirc ${D}/var/www/qwebirc
+
+ # create the logfile as qwebirc does not have the permission to create it itself
+ mkdir -p ${D}/var/log
+ touch ${D}/var/log/qwebirc
+ chown qwebirc:qwebirc ${D}/var/log/qwebirc
+ chmod 640 ${D}/var/log/qwebirc
+
+ mkdir -p ${D}/etc/init.d
+ cp ${FILESDIR}/init-script ${D}/etc/init.d/qwebirc
+ chmod 755 ${D}/etc/init.d/qwebirc
+
+ mkdir -p ${D}/etc/conf.d
+ echo "PORT=9090" > ${D}/etc/conf.d/qwebirc
+}