aboutsummaryrefslogtreecommitdiffstats
path: root/app-text/kindlegen/kindlegen-2.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-text/kindlegen/kindlegen-2.9-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-text/kindlegen/kindlegen-2.9-r1.ebuild b/app-text/kindlegen/kindlegen-2.9-r1.ebuild
new file mode 100644
index 0000000..2418f9b
--- /dev/null
+++ b/app-text/kindlegen/kindlegen-2.9-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit versionator
+
+DESCRIPTION="Command line tool for Amazon Kindle publishing."
+HOMEPAGE="http://www.amazon.com/gp/feature.html?docId=1000765211"
+
+MY_PV=$(replace_all_version_separators '_')
+SRC_FILE="${PN}_linux_2.6_i386_v${MY_PV}.tar.gz"
+SRC_URI="http://kindlegen.s3.amazonaws.com/${SRC_FILE}"
+RESTRICT="mirror strip"
+
+LICENSE="KindleGen-EULA"
+SLOT="0"
+KEYWORDS="~i686 ~amd64"
+LANGUAGES="linguas_fr linguas_it linguas_de linguas_en linguas_es linguas_jp linguas_zh"
+IUSE="${LANGUAGES}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-libs/glibc"
+
+S=${WORKDIR}
+
+src_install() {
+ dobin kindlegen || die
+
+ if use linguas_en ; then
+ docinto /
+ dodoc EULA.txt
+ docinto english
+ dodoc docs/english/*
+ fi
+
+ if use linguas_de ; then
+ docinto /
+ dodoc EULA_German.txt
+ docinto german
+ dodoc docs/german/*
+ fi
+
+ if use linguas_it ; then
+ docinto /
+ dodoc EULA_Italian.txt
+ docinto italian
+ dodoc docs/italian/*
+ fi
+
+ if use linguas_fr ; then
+ docinto /
+ dodoc EULA_Frensh.txt
+ docinto frensh
+ dodoc docs/frensh/*
+ fi
+
+ if use linguas_es ; then
+ docinto /
+ dodoc EULA_Spanish.txt
+ docinto spanish
+ dodoc docs/spanish/*
+ fi
+
+ if use linguas_jp ; then
+ docinto /
+ dodoc EULA_Japanese.txt
+ docinto japanese
+ dodoc docs/japanese/*
+ fi
+
+ if use linguas_zh ; then
+ docinto /
+ dodoc EULA_Chinese.txt
+ docinto chinese
+ dodoc docs/chinese/*
+ fi
+}