aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xmonad/xmonad-9999.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2010-12-12 23:15:29 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2010-12-12 23:15:29 +0100
commitcd8d1e236d0a81b44b835a592c89ecf66977ebe3 (patch)
tree8b86a5e5d5a25cf6e48ab79ddb1d9f140c2ae0f6 /x11-wm/xmonad/xmonad-9999.ebuild
parent5f930f9c762bdbff3acfb774778b078f9671b570 (diff)
downloadoverlay-cd8d1e236d0a81b44b835a592c89ecf66977ebe3.tar.gz
overlay-cd8d1e236d0a81b44b835a592c89ecf66977ebe3.tar.xz
overlay-cd8d1e236d0a81b44b835a592c89ecf66977ebe3.zip
x11-wm: added xmonad, xmonad-contrib ebuilds that use the git mirror repositories
Diffstat (limited to '')
-rw-r--r--x11-wm/xmonad/xmonad-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-wm/xmonad/xmonad-9999.ebuild b/x11-wm/xmonad/xmonad-9999.ebuild
new file mode 100644
index 0000000..f997387
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+
+inherit haskell-cabal git
+
+DESCRIPTION="A tiling window manager"
+HOMEPAGE="http://xmonad.org"
+EGIT_REPO_URI="git://git.animux.de/xmonad"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10
+ dev-haskell/mtl
+ >=dev-haskell/x11-1.5"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+SAMPLE_CONFIG="xmonad.hs"
+SAMPLE_CONFIG_LOC="man"
+
+src_install() {
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/xmonad" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ doman man/xmonad.1
+
+ dodoc CONFIG README
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/${PF}/ghc-$(ghc-version)/${SAMPLE_CONFIG_LOC}/${SAMPLE_CONFIG}"
+ elog "The parameters in this file are the defaults used by xmonad."
+ elog "To customize xmonad, copy this file to:"
+ elog " ~/.xmonad/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart xmonad "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}