aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/tt-rss/tt-rss-1.4.1.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2011-09-13 23:13:58 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2011-09-13 23:13:58 +0200
commite13bf217d2f0071062c6728640c13b4a4de8e3b8 (patch)
tree9b22fe1b8632c04b224096ebc2857a1fd18a66b9 /www-apps/tt-rss/tt-rss-1.4.1.ebuild
parentccf91f5b973e5433ba94dd02de35600513a750de (diff)
downloadoverlay-e13bf217d2f0071062c6728640c13b4a4de8e3b8.tar.gz
overlay-e13bf217d2f0071062c6728640c13b4a4de8e3b8.tar.xz
overlay-e13bf217d2f0071062c6728640c13b4a4de8e3b8.zip
www/tt-rss: removed, its now in portage tree
Diffstat (limited to '')
-rw-r--r--www-apps/tt-rss/tt-rss-1.4.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/www-apps/tt-rss/tt-rss-1.4.1.ebuild b/www-apps/tt-rss/tt-rss-1.4.1.ebuild
deleted file mode 100644
index 03ed058..0000000
--- a/www-apps/tt-rss/tt-rss-1.4.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit webapp depend.php depend.apache
-
-DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
-HOMEPAGE="http://tt-rss.org/"
-SRC_URI="http://tt-rss.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64"
-IUSE="mysql postgres"
-
-DEPEND="dev-lang/php[mysql?,postgres?]"
-RDEPEND="${DEPEND}"
-
-need_httpd_cgi
-need_php_httpd
-
-pkg_setup() {
- webapp_pkg_setup
- use mysql && require_php_with_use mysql
- use postgres && require_php_with_use postgres
-}
-
-src_prepare() {
- # Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
- einfo "Customizing config.php..."
- mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
- if ( use mysql || use mysqli ) && ! use postgres; then
- sed -e "/define('DB_TYPE',/{s:pgsql:mysql:}" -i config.php || die "sed failed"
- fi
- sed -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" -i config.php \
- || die "sed failed"
-}
-
-src_install() {
- webapp_src_preinst
-
- insinto "/${MY_HTDOCSDIR}"
- doins -r * || die "Could not copy the files to ${MY_HTDOCSDIR}."
- keepdir "/${MY_HTDOCSDIR}"/icons
-
- webapp_serverowned "${MY_HTDOCSDIR}"/icons
- webapp_configfile "${MY_HTDOCSDIR}"/config.php
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}
-
-pkg_postinst() {
- elog "If you want to use the update daemon, you could find"
- elog "a conf.d file and an init script in ${FILESDIR}."
-}