aboutsummaryrefslogtreecommitdiffstats
path: root/mail-client/roundcube/roundcube-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2010-09-25 11:35:20 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2010-09-25 11:40:36 +0200
commitc8d130044762aeb126ec64f188fc2950dd43f5df (patch)
tree54423f29d2233b322f37fe99f6e2a537b7c5f92a /mail-client/roundcube/roundcube-0.3.1-r1.ebuild
parent116b84783fd6e13dbd9414ae982e48982a4a0f59 (diff)
downloadoverlay-c8d130044762aeb126ec64f188fc2950dd43f5df.tar.gz
overlay-c8d130044762aeb126ec64f188fc2950dd43f5df.tar.xz
overlay-c8d130044762aeb126ec64f188fc2950dd43f5df.zip
added roundcube fix for >dev-lang/php-5.3
Diffstat (limited to '')
-rw-r--r--mail-client/roundcube/roundcube-0.3.1-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/mail-client/roundcube/roundcube-0.3.1-r1.ebuild b/mail-client/roundcube/roundcube-0.3.1-r1.ebuild
new file mode 100644
index 0000000..5f49776
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.3.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV}"
+
+inherit webapp depend.php depend.apache
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres ssl spell"
+
+DEPEND=""
+RDEPEND="|| ( <dev-lang/php-5.3[pcre,spl] >=dev-lang/php-5.3 )
+ dev-lang/php[crypt,iconv,ldap?,postgres?,session,ssl?,unicode]
+
+ !postgres? ( !mysql? ( dev-lang/php[sqlite] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ dev-php/PEAR-PEAR
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ use mysql && require_php_with_any_use mysql mysqli
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}