aboutsummaryrefslogtreecommitdiffstats
path: root/dev-util/mfoc/mfoc-9999.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2012-06-06 02:04:57 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2012-06-06 02:04:57 +0200
commit2563686e0444b1800e04468e49d45b4c18a6c17b (patch)
tree1fc0c587309fcbefa894400b6f7a73f03286f8ee /dev-util/mfoc/mfoc-9999.ebuild
parent7fca6728e258058e176df854127f10acc0a6e03f (diff)
downloadoverlay-2563686e0444b1800e04468e49d45b4c18a6c17b.tar.gz
overlay-2563686e0444b1800e04468e49d45b4c18a6c17b.tar.xz
overlay-2563686e0444b1800e04468e49d45b4c18a6c17b.zip
dev-utils/mfoc: add live ebuild (requires new libnfc)
Diffstat (limited to '')
-rw-r--r--dev-util/mfoc/mfoc-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/mfoc/mfoc-9999.ebuild b/dev-util/mfoc/mfoc-9999.ebuild
new file mode 100644
index 0000000..79c1a65
--- /dev/null
+++ b/dev-util/mfoc/mfoc-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils subversion autotools
+
+DESCRIPTION="Mifare Classic Offline Cracker is a tool that can recover keys from Mifare Classic cards"
+HOMEPAGE="http://code.google.com/p/nfc-tools/"
+ESVN_REPO_URI="http://nfc-tools.googlecode.com/svn/trunk/mfoc/"
+ESVN_PROJECT="mfoc"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+CDEPEND=">=dev-libs/libnfc-1.5.1"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ eautoreconf || die "autoreconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog AUTHORS NEWS TODO || die
+}