aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eb7634323..8170badbe 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,6 +11,7 @@ mpd_CPPFLAGS = \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS)) \
$(AUDIOFILE_CFLAGS) $(LIBMIKMOD_CFLAGS) \
$(MODPLUG_CFLAGS) \
+ $(SIDPLAY_CFLAGS) \
$(ID3TAG_CFLAGS) \
$(MAD_CFLAGS) \
$(FFMPEG_CFLAGS) \
@@ -24,6 +25,7 @@ mpd_LDADD = $(MPD_LIBS) \
$(OGGVORBIS_LIBS) $(VORBISENC_LIBS) $(FLAC_LIBS) \
$(AUDIOFILE_LIBS) $(LIBMIKMOD_LIBS) \
$(MODPLUG_LIBS) \
+ $(SIDPLAY_LIBS) \
$(ID3TAG_LIBS) \
$(MAD_LIBS) \
$(MP4FF_LIBS) \
@@ -311,6 +313,10 @@ if HAVE_MODPLUG
mpd_SOURCES += decoder/modplug_plugin.c
endif
+if ENABLE_SIDPLAY
+mpd_SOURCES += decoder/sidplay_plugin.cxx
+endif
+
if HAVE_FFMPEG
mpd_SOURCES += decoder/ffmpeg_plugin.c
endif