aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 38ba8b223..b327a8f93 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -158,10 +158,7 @@ mpd_SOURCES = \
volume.c \
locate.c \
stored_playlist.c \
- timer.c \
- archive_api.c \
- archive_list.c \
- input_archive.c
+ timer.c
if HAVE_LIBSAMPLERATE
mpd_SOURCES += pcm_resample_libsamplerate.c
@@ -187,6 +184,14 @@ if HAVE_ISO
mpd_SOURCES += archive/iso_plugin.c
endif
+if ENABLE_ARCHIVE
+mpd_SOURCES += \
+ archive_api.c \
+ archive_list.c \
+ input_archive.c
+endif
+
+
# decoder plugins
if HAVE_MAD