aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ad4ad99f3..38ba8b223 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -81,7 +81,10 @@ mpd_headers = \
zeroconf.h \
locate.h \
stored_playlist.h \
- timer.h
+ timer.h \
+ archive_api.h \
+ archive_list.h \
+ input_archive.h
mpd_SOURCES = \
@@ -155,7 +158,10 @@ mpd_SOURCES = \
volume.c \
locate.c \
stored_playlist.c \
- timer.c
+ timer.c \
+ archive_api.c \
+ archive_list.c \
+ input_archive.c
if HAVE_LIBSAMPLERATE
mpd_SOURCES += pcm_resample_libsamplerate.c
@@ -167,6 +173,19 @@ if HAVE_ID3TAG
mpd_SOURCES += tag_id3.c
endif
+# archive plugins
+
+if HAVE_BZ2
+mpd_SOURCES += archive/bz2_plugin.c
+endif
+
+if HAVE_ZIP
+mpd_SOURCES += archive/zip_plugin.c
+endif
+
+if HAVE_ISO
+mpd_SOURCES += archive/iso_plugin.c
+endif
# decoder plugins