aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f9fe0b0cf..6a8894cbe 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -79,7 +79,7 @@ mpd_headers = \
utils.h \
volume.h \
ioops.h \
- zeroconf.h \
+ zeroconf.h zeroconf-internal.h \
locate.h \
stored_playlist.h \
timer.h \
@@ -256,6 +256,14 @@ endif
if HAVE_ZEROCONF
mpd_SOURCES += zeroconf.c
+
+if HAVE_AVAHI
+mpd_SOURCES += zeroconf-avahi.c
+endif
+
+if HAVE_BONJOUR
+mpd_SOURCES += zeroconf-bonjour.c
+endif
endif