aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f2bf55eb1..47a121484 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,6 +66,7 @@ mpd_headers = \
path.h \
mapper.h \
pcm_utils.h \
+ pcm_resample.h \
pcm_dither.h \
permission.h \
player_thread.h \
@@ -146,6 +147,7 @@ mpd_SOURCES = \
path.c \
mapper.c \
pcm_utils.c \
+ pcm_resample.c \
pcm_dither.c \
permission.c \
player_thread.c \
@@ -176,6 +178,12 @@ mpd_SOURCES = \
stored_playlist.c \
timer.c
+if HAVE_LIBSAMPLERATE
+mpd_SOURCES += pcm_resample_libsamplerate.c
+else
+mpd_SOURCES += pcm_resample_fallback.c
+endif
+
if HAVE_ID3TAG
mpd_SOURCES += tag_id3.c
endif