aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b375d85a..5d9f3bdf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -722,6 +722,18 @@ else
echo " MOD support ...................disabled"
fi
+if
+ test x$enable_mp3 = xno &&
+ test x$enable_oggvorbis = xno &&
+ test x$enable_flac = xno &&
+ test x$enable_oggflac = xno &&
+ test x$enable_audiofile = xno &&
+ test x$enable_aac = xno &&
+ test x$enable_mpc = xno &&
+ test x$enable_mod = xno; then
+ AC_MSG_ERROR("No input plugins supported!")
+fi
+
echo ""
echo "##########################################"
echo ""