aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2e0a232e..e5f728008 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,18 @@ else
fi
+dnl disbale raw mode
+AC_MSG_CHECKING([Place the terminal into raw mode])
+AC_ARG_ENABLE([raw-mode],
+ AC_HELP_STRING([--disable-raw-mode],
+ [Disable raw terminal mode]),
+ [use_raw=$enableval],
+ [use_raw=yes])
+AC_MSG_RESULT([$use_raw])
+if test "x$use_raw" = "xyes" ; then
+ AC_DEFINE([ENABLE_RAW_MODE], [1], [Place the terminal into raw mode])
+fi
+
dnl Debugging
AC_MSG_CHECKING([whether to build with debug support])
AC_ARG_ENABLE([debug],