aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f750aa90f..585f63b8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -613,8 +613,8 @@ AM_CONDITIONAL(HAVE_PULSE, test x$enable_pulse = xyes)
AC_ARG_ENABLE(httpd-output,
AS_HELP_STRING([--enable-httpd-output],
- [enables the HTTP server output (default: disable)]),,
- [enable_httpd_output=no])
+ [enables the HTTP server output]),,
+ [enable_httpd_output=auto])
enable_osx=no
case "$host_os" in
@@ -980,6 +980,17 @@ if test x$enable_shout = xauto; then
fi
fi
+if test x$enable_httpd_output = xauto; then
+ # handle HTTPD auto-detection: disable if no encoder is
+ # available
+ if test x$enable_encoder = xyes; then
+ enable_httpd_output=yes
+ else
+ AC_MSG_WARN([No encoder plugin -- disabling the HTTP output plugin])
+ enable_httpd_output=no
+ fi
+fi
+
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
AM_CONDITIONAL(ENABLE_HTTPD_OUTPUT, test x$enable_httpd_output = xyes)