aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 12 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6f6711792..187d2bd59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1006,16 +1006,21 @@ dnl
dnl Documentation
dnl
-AC_MSG_CHECKING([for xmlto (DocBook processing)])
-AC_PATH_PROG(XMLTO, xmlto)
-if test x$XMLTO != x; then
+AC_ARG_ENABLE(documentation,
+ AS_HELP_STRING([--enable-documentation],
+ [build documentation (default: disable)]),,
+ [enable_documentation=no])
+
+if test x$enable_documentation = xyes; then
+ AC_PATH_PROG(XMLTO, xmlto)
+ if test x$XMLTO = x; then
+ AC_MSG_ERROR([xmlto not found])
+ fi
+
AC_SUBST(XMLTO)
- AC_MSG_RESULT($XMLTO)
-else
- AC_MSG_RESULT(no)
fi
-AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
+AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
dnl