aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ddebb0bdc..653bea29d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,8 @@ dnl
dnl declare variables
dnl
+AC_SUBST(AM_CFLAGS,"")
+
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
MPD_LIBS=""
@@ -1105,7 +1107,7 @@ AC_ARG_ENABLE(werror,
ENABLE_WERROR=no)
if test "x$ENABLE_WERROR" = xyes; then
- MPD_CFLAGS="$MPD_CFLAGS -Werror -pedantic-errors"
+ AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
fi
AC_ARG_ENABLE(debug,
@@ -1116,7 +1118,7 @@ AC_ARG_ENABLE(debug,
#if test "x$ENABLE_DEBUG" = xno; then
# don't set NDEBUG for now, until MPD is stable
- #MPD_CFLAGS="$MPD_CFLAGS -DNDEBUG"
+ #AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
#fi
AC_ARG_ENABLE(gprof,