aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 583659426..172e4decb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -969,14 +969,10 @@ fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
dnl -------------------------------- Ogg Vorbis -------------------------------
-if test x$enable_tremor != xyes && test x$enable_vorbis = xyes; then
+if test x$enable_tremor != xno && test x$enable_vorbis = xyes; then
PKG_CHECK_MODULES(VORBIS, [ogg vorbis vorbisfile],
-
-fi
-
-if test x$enable_vorbis = xyes; then
- AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
- enable_vorbis=no)
+ AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
+ enable_vorbis=no)
fi
AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)