aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8ae21793a..ff64bee06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,6 +195,12 @@ AC_ARG_ENABLE(un,
[disable support for clients connecting via unix domain sockets (default: enable)]),,
[enable_un=yes])
+case "$host_os" in
+mingw* | windows*)
+ enable_un=no
+ ;;
+esac
+
if test x$enable_un = xyes; then
AC_DEFINE(HAVE_UN, 1, [Define if unix domain socket support is enabled])
STRUCT_UCRED
@@ -1139,12 +1145,20 @@ MPD_AUTO_PKG(vorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
if test x$enable_lame_encoder != xno; then
- AM_PATH_LAME([found_lame_encoder=yes], [found_lame_encoder=no])
- MPD_AUTO_RESULT(lame_encoder, [LAME encoder plugin],
- [LAME not found])
+ AC_CHECK_HEADERS(lame/lame.h,,
+ [AC_CHECK_HEADERS(lame.h,, using_lame=no)])
+ AC_CHECK_LIB(mp3lame, lame_init,, using_lame=no)
+ if test x$using_lame != xno; then
+ AC_DEFINE(HAVE_LAME, 1, [Define to 1 if you have lame 3.98 or greater.])
+ LAME_LIBS="-lmp3lame -lm"
+ enable_lame_encoder=yes
+ fi
+
+ if test "$enable_lame_encoder" = "yes" -a "$using_lame" = "no"; then
+ AC_MSG_ERROR([LAME libraries and development support files not found.])
+ fi
fi
-AC_SUBST(LAME_CFLAGS)
AC_SUBST(LAME_LIBS)
MPD_AUTO_PKG(twolame_encoder, TWOLAME, [twolame],