aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2dfdff333..a9929f237 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@ dnl initialize variables
dnl =======================================================
dnl i18n
-ALL_LINGUAS="es de fr ru sv"
+ALL_LINGUAS="es de fr no ru sv"
set -- $CFLAGS
@@ -159,6 +159,18 @@ if test "x$getmouse" = "xyes" ; then
[])
fi
+dnl artist screen
+AC_MSG_CHECKING([whether to include the artist screen])
+AC_ARG_ENABLE([artist-screen],
+ AC_HELP_STRING([--enable-artist-screen],
+ [Enable artist screen (EXPERIMENTAL) @<:@default=no@:>@]),
+ [artist_screen="$enableval"],
+ [artist_screen=no])
+AC_MSG_RESULT([$artist_screen])
+if test "x$artist_screen" != "xyes" ; then
+ AC_DEFINE(DISABLE_ARTIST_SCREEN, 1, [Disable artist screen])
+fi
+
dnl search screen
AC_MSG_CHECKING([whether to include the search screen])
AC_ARG_ENABLE([search-screen],