aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4a9a7da0..5de3a3244 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,6 +312,20 @@ if test "x$search_screen" = "xyes" ; then
fi
AM_CONDITIONAL(ENABLE_SEARCH_SCREEN, test x$search_screen = xyes)
+
+dnl Optional screen - song viewer
+AC_MSG_CHECKING([whether to include the song viewer screen])
+AC_ARG_ENABLE([song-screen],
+ AC_HELP_STRING([--enable-song-screen],
+ [Enable song viewer screen @<:@default=yes@:>@]),
+ [song_screen="$enableval"],
+ [song_screen=$disable_mini])
+AC_MSG_RESULT([$song_screen])
+if test "x$song_screen" = "xyes" ; then
+ AC_DEFINE(ENABLE_SONG_SCREEN, 1, [Enable song viewer screen])
+fi
+
+AM_CONDITIONAL(ENABLE_SONG_SCREEN, test x$song_screen = xyes)
dnl Optional screen - key editor
AC_MSG_CHECKING([whether to include the key editor screen])