aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c45574b0b..15fc7549d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -829,6 +829,9 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
+AC_SUBST(OPENAL_CFLAGS,"")
+AC_SUBST(OPENAL_LIBS,"")
+
if test x$enable_openal = xyes; then
if test x$enable_osx = xyes; then
AC_CHECK_HEADERS([OpenAL/al.h OpenAL/alc.h], [], [enable_openal=no])
@@ -845,11 +848,6 @@ if test x$enable_openal = xyes; then
fi
fi
-if test x$enable_openal = xyes; then
- MPD_CFLAGS="$MPD_CFLAGS $OPENAL_CFLAGS"
- MPD_LIBS="$MPD_LIBS $OPENAL_LIBS"
-fi
-
AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)
if test x$enable_fifo = xyes; then