aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4ff334c8f..1f8f4f75d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1019,14 +1019,10 @@ if test x$enable_tremor = xyes; then
elif test "x$tremor_prefix" != "x" ; then
TREMOR_CFLAGS="-I$tremor_prefix/include"
fi
- ac_save_CFLAGS="$CFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $TREMOR_CFLAGS"
- LIBS="$LIBS $TREMOR_LIBS"
- AC_CHECK_LIB(vorbisidec,ov_read,,enable_tremor=no;
- AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
+
+ MPD_WITH_LIBRARY([TREMOR],
+ [AC_CHECK_LIB(vorbisidec,ov_read,,enable_tremor=no;
+ AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))])
fi
if test x$enable_tremor = xyes; then