aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 323a24298..9cda77546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,21 @@ dnl
dnl Check for libraries
dnl
+dnl Try to find the socket functions
+AC_CHECK_FUNC([socket],
+ [],
+ [AC_CHECK_LIB([socket],[socket],[LIBS="$LIBS -lsocket"],
+ [AC_MSG_ERROR(No UNIX socket API found)])
+ ])
+
+dnl Try to find the gethostbyname functions
+AC_CHECK_FUNC([gethostbyname],
+ [],
+ [AC_CHECK_LIB([nsl],[gethostbyname],[LIBS="$LIBS -lnsl"],
+ [AC_MSG_ERROR(No UNIX gethostbyname API found)])
+ ])
+
+
dnl ncurses
ncurses=ncursesw
AC_ARG_WITH([ncurses],